บล็อค Torrents

ตัวอย่างเป็นการบล็อก แลนวง  192.168.1.0/24
แล้วแทนที่ ด้วยไอพี อื่น ดังนี้

เปิด WinBOX คลิกไปที่ IP แล้วคลิกไปที่ firewall layer7-protocol

/ip firewall layer7-protocol>
คลิก เพิ่มชื่อ  name=torrentsites
ใช้สคริป regexp ดังนี้:

 

แล้วคลิกไปที่  firewall filter

/ip firewall filter>

# บล็อค โปรโตคอล torrentsites
add chain=forward src-address=192.168.1.0/24 layer7-protocol=torrentsites action=drop comment=torrentsites

# บล็อค พอร์ต 53
add chain=forward src-address=192.168.1.0/24 protocol=17 dst-port=53 layer7-protocol=torrentsites action=drop comment=dropDNS

# บล็อค keyword คำว่า torrent
add chain=forward src-address=192.168.1.0/24 content=torrent action=drop comment=keyword_drop

# บล็อค keyword คำว่า tracker
add chain=forward src-address=192.168.1.0/24 content=tracker action=drop comment=trackers_drop

# บล็อค keyword คำว่า getpeers
add chain=forward src-address=192.168.1.0/24 content=getpeers action=drop comment=get_peers_drop

# บล็อค keyword คำว่า info_hash
add chain=forward src-address=192.168.1.0/24 content=info_hash action=drop comment=info_hash_drop

# บล็อค keyword คำว่า announce_peers
add chain=forward src-address=192.168.1.0/24 content=announce_peers action=drop comment=announce_peers_drop