จัดการความเร็วของ Video Stream Bandwidth ด้วย Mikrotik.

1. Login เข้าใช้ Mikrotik ด้วย WinBox
คลิกที่  IP  แล้วคลิก Firewall, เลือกแท๊ป Layer7 Protocols, แล้วคลิกปุ่ม + ใส่ Regexp ดังนี้.

/ip firewall layer7-protocol
add comment="" name=streaming regexp="videoplayback|video"

2. คลิกเลือกแท๊ป  Mangle คลิก new mangle rule แล้วตั้งค่าตามนี้.

/ip firewall mangle
add chain=prerouting action=mark-connection new-connection-mark=video_stream \
comment="Mark Streaming" passthrough=yes src-address-list=Youtuber in-interface=bridge-local

add chain=prerouting action=mark-packet new-packet-mark=video_stream_packet \
passthrough=yes connection-mark=video_stream

3. คลิก  Queues  คลิกเพิ่ม queue rule ดังนี้.

/queue simple
add name=Limit_Video_Day target-addresses=192.168.88.0/24 \
direction=both disabled=no interface=bridge-local limit-at=128k/128k max-limit=256k/256k \
packet-marks=video_stream_packet parent=none priority=8 \
queue=default-small/default-small burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s \
total-queue=default-small
add name=Limit_Video_Night target-addresses=192.168.88.0/24 \
direction=both disabled=yes interface=bridge-local limit-at=0/3M max-limit=0/3M \
packet-marks=video_stream_packet parent=none priority=8 \
queue=default-small/default-small burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s \
total-queue=default-small

ดังในตัวอย่าง, กำหนดความเร็ว 256kbps ในเวลากลางวัน และ 3Mbps ในเวลากลางคืน
Day = 06:00am – 18:00pm – 256kbps. <Max-Limit>
Night = 18:00pm – 06:00am – 3Mbps. <Max-Limit>

4. การเขียนสคริป ให้คลิก  System คลิกเพิ่ม  Script ดังนี้

/system script
add name=Limit_Video_Day source="/queue simple enable Limit_Video_Day; \
/queue simple disable Limit_Video_Night"
add name=Limit_Video_Night source="/queue simple enable Limit_Video_Night; \
/queue simple disable Limit_Video_Day"

5. ตั้งตารางเวลา โดย คลิก System แล้วคลิก Scheduler แล้วเพิ่ม และกำหนดค่าดังนี้

/system scheduler
add disabled=no interval=1d name=Limit_Video_Day on-event=Limit_Video_Day \
start-date=oct/10/2014 start-time=06:00:00
add disabled=no interval=1d name=Limit_Video_Night on-event=Limit_Video_Night \
start-date=oct/10/2014 start-time=18:00:00